All Systems Operational
Portland data center Operational
90 days ago
99.99 % uptime
Today
US cluster ? Operational
90 days ago
99.99 % uptime
Today
US2 cluster ? Operational
90 days ago
100.0 % uptime
Today
Dublin data center Operational
90 days ago
99.95 % uptime
Today
EU cluster ? Operational
90 days ago
99.96 % uptime
Today
EU2 cluster ? Operational
90 days ago
99.95 % uptime
Today
POVEU cluster ? Operational
90 days ago
99.95 % uptime
Today
Sydney data center Operational
90 days ago
99.97 % uptime
Today
APAC cluster ? Operational
90 days ago
99.97 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
May 20, 2024

No incidents reported today.

May 19, 2024

No incidents reported.

May 18, 2024

No incidents reported.

May 17, 2024

No incidents reported.

May 16, 2024
Completed - The scheduled maintenance has been completed.
May 16, 07:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
May 16, 00:00 UTC
Scheduled - Maintenance will begin at 12:00AM UTC, outside of working hours.
May 15, 12:50 UTC
May 15, 2024
Completed - The scheduled maintenance has been completed.
May 15, 12:35 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
May 15, 12:00 UTC
Scheduled - We will be undergoing scheduled maintenance during this time.
May 16, 00:00 UTC
Completed - The scheduled maintenance has been completed.
May 15, 00:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
May 14, 17:00 UTC
Scheduled - We will be undergoing scheduled maintenance during this time.
May 3, 11:53 UTC
May 14, 2024
May 13, 2024

No incidents reported.

May 12, 2024

No incidents reported.

May 11, 2024

No incidents reported.

May 10, 2024

No incidents reported.

May 9, 2024
Completed - The scheduled maintenance has been completed.
May 9, 08:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
May 9, 01:00 UTC
Scheduled - We will be undergoing scheduled maintenance during this time.
Apr 30, 13:51 UTC
May 8, 2024

No incidents reported.

May 7, 2024

No incidents reported.

May 6, 2024

No incidents reported.