Monitoring - We continue to monitor the load on the cluster.
Mar 28, 2024 - 20:17 UTC
Update - We continue to investigate and monitor the performance issues in the cluster.
Mar 28, 2024 - 19:05 UTC
Update - The investigation of the issue is still in progress.
Mar 28, 2024 - 17:45 UTC
Update - We keep looking into the issue. The investigation is still in progress.
Mar 28, 2024 - 16:33 UTC
Update - We continue to investigate the performance issues in the cluster.
Mar 28, 2024 - 15:04 UTC
Investigating - We are experiencing performance degradation on accounts hosted in US cluster. We are working diligently to resolve this issue.
Mar 28, 2024 - 14:01 UTC
Portland data center Degraded Performance
90 days ago
99.8 % uptime
Today
US cluster ? Degraded Performance
90 days ago
99.96 % uptime
Today
US2 cluster ? Operational
90 days ago
99.65 % uptime
Today
Dublin data center Operational
90 days ago
99.95 % uptime
Today
EU cluster ? Operational
90 days ago
99.93 % uptime
Today
EU2 cluster ? Operational
90 days ago
99.97 % uptime
Today
POVEU cluster ? Operational
90 days ago
99.96 % uptime
Today
Sydney data center Operational
90 days ago
99.97 % uptime
Today
APAC cluster ? Operational
90 days ago
99.97 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
We will be migrating the internal storage for the reporting module to a newer version. This migration will enable delivering an improved performance for the reporting module. The reports will be unavailable for up to 3 hours during the maintenance window.
Posted on Mar 14, 2024 - 11:44 UTC
We will be migrating the internal storage for the reporting module to a newer version. This migration will enable delivering an improved performance for the reporting module. The reports will be unavailable during the entire maintenance window.
Posted on Mar 28, 2024 - 08:49 UTC
Past Incidents
Mar 28, 2024

Unresolved incident: Degraded Performance in US cluster.

Mar 27, 2024
Resolved - We have resolved the issue and your services have been restored.

If you are still experiencing issues, please create a request in the Support Portal https://servicedesk.targetprocess.com/

Mar 27, 22:19 UTC
Update - We are still actively working on a fix for the ongoing issue.
Mar 27, 21:30 UTC
Update - We are actively working on a fix for the ongoing issue.
Mar 27, 20:22 UTC
Update - We are still experiencing an issue which may cause a degradation of service. We continue to work diligently to resolve this and will provide regular updates on our progress until we have done so.

Currently, you may experience performance issues. We apologize for any inconvenience this interruption may have caused you.

Mar 27, 19:22 UTC
Investigating - We are currently experiencing an issue which may cause a degradation of service. We are working diligently to resolve this and will provide regular updates on our progress.

Currently, you may experience performance issues. We apologize for any inconvenience this interruption may have caused you.

Mar 27, 18:18 UTC
Completed - The scheduled maintenance has been completed.
Mar 27, 15:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 27, 11:00 UTC
Scheduled - We will be migrating the internal storage for the reporting module to a newer version. This migration will enable delivering an improved performance for the reporting module. The reports will be unavailable for up to 3 hours during the maintenance window.
Mar 14, 10:05 UTC
Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024
Completed - The scheduled maintenance has been completed.
Mar 23, 11:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 23, 08:00 UTC
Scheduled - Migration of Apptio Targetprocess backend services to a modernized cloud infrastructure platform, aiming to enhance security, improve scalability and performance, and establish a more mature infrastructure management process. The migration process does not involve neither any data movements, nor external interfaces changes. Only the backend workloads are moved to be hosted on the modernized environment. Targetprocess will be unavailable during the maintenance window.
Mar 1, 15:36 UTC
Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024
Completed - The scheduled maintenance has been completed.
Mar 16, 11:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 16, 08:00 UTC
Scheduled - Migration of Apptio Targetprocess backend services to a modernized cloud infrastructure platform, aiming to enhance security, improve scalability and performance, and establish a more mature infrastructure management process. The migration process does not involve neither any data movements, nor external interfaces changes. Only the backend workloads are moved to be hosted on the modernized environment. Targetprocess will be unavailable during the maintenance window.
Mar 1, 15:34 UTC
Mar 15, 2024

No incidents reported.

Mar 14, 2024

No incidents reported.